WordPress 2.5 – ikaldus majas

31.03.2008 @ 9:32:20 | Aarne Toompark | 13 kommentaari

Eile kirjutasin rÔÔmsalt sellest, kuidas ma hunniku blogisid uuele versioonile uuendasin.

TĂ€na ma enam nii rÔÔmus ei ole. Nimelt kĂ”ik töötab korralikult peale selle, et kĂ”ik lehekĂŒljed annavad 404 veateate. Supordifoorumitest lugesin, et ka teistel on niisugust jama. Kahjuks hetkel head lahendust ei ole. :(

Viga on kuidagi seotud permalinkidega. Mina kasutan niisugust struktuuri: /index.php/%postname%/. Neil, kes kasutavad "tavalist" (default, /?p=xxx) struktuuri, ei tohiks viga avalduda.

Otsin endiselt lahendust ja struktuuri muutma hakata kĂŒll ei tahaks. See tooks endaga kaasa hunniku katkiseid linke ja ei lahendaks tegelikult probleemi.

  1. 13 kommentaari postitusele "WordPress 2.5 – ikaldus majas"

  2. Mul veidi teistsugune mure.
    Tegin Linnarile ka blogiuuenduse Ă€ra ja mĂ€ssasin baasiga, aga see phpadmin kurivaim keeras charseti tuksi ja nĂŒĂŒd tulemust vĂ”id ise kaeda linnar.viik.ee

    Kas oskad mingit head lahendust vĂ€lja pakkuda? Suppordi foorumist lugesin, aga ĂŒmber convertimine tundus pĂ€ris suur töö olevat…

    kirjutas Allar 31.03.2008 @ 10:05

  3. Äkki aitab niisugune asi, kui failis wp-includes/wp-db.php muuta rida 88 niisuguseks: $this->query(“SET NAMES ‘utf8′”);

    Tegemist on muidugi labase hÀkiga ja parem oleks baas Ôige kodeeringu peale tagasi konvertida.

    kirjutas Aarne 31.03.2008 @ 10:35

  4. Mina pĂŒĂŒan viimasel ajal dumpimise ja importimise juures phpmyadminni vĂ€ltida, mul ka mitu (Ă”nneks vĂ€iksemat) asja katki teinud, lĂ”puks pÀÀstis ainult kĂ€sitsi kĂ”igi katkiste sĂŒmbolite parandamine…

    kirjutas Urmas 31.03.2008 @ 10:37

  5. Kurat, korras! AitÀh! :D

    Nagu ma aru sain, siis probleem tekkis sellest, et phpmyadmin exportis sisu Latin1 charsetis faili, mis oli utf8 kodeeringus ja kÔik eritÀhed keerati tuksi. Kas sain Ôigesti aru?

    kirjutas Allar 31.03.2008 @ 10:53

  6. Usun kĂŒll. Kunagi Ă”nnestus mul ka endal niisugune asi teha. Kuidas pĂ€rast Ă€ra parandasin, seda ei mĂ€leta. Kuidagi ma selle asja igatahes korda sain.

    kirjutas Aarne 31.03.2008 @ 11:01

  7. Kas nii ei saa, et kustutad vanad tabelid alt Àra ja impordid Ôige charsetiga dumpi uuesti?

    kirjutas Aare 31.03.2008 @ 11:13

  8. Noh, dump failis on tĂ€hed juba sassis ja kui importimisel valida Latin1 vĂ”i utf8 ei muuda see nagu midagi…
    VÔi kuidas ma muudan charseti failis?
    Mul editplus, aga see ei tee konverti?

    kirjutas Allar 31.03.2008 @ 11:54

  9. Ainuke lahendus ongi vist otse vÀljundit jooksvalt konvertida, nagu Aarne soovitas.
    Ma ei osanud seda lihtsalt teostada ;)

    kirjutas Allar 31.03.2008 @ 11:55

  10. WordPressi andmebaasi enkodingu muutmise kohta leidsin niisuguse Ôpetuse: http://alexking.org/blog/2008/03/06/mysql-latin1-utf8-conversion

    Supordifoorumeid lugedes leidsin, et lehekĂŒlgede nĂ€itamise asemel 404 andmine paistab olevat kĂ”igi WP2.5 ja /index.php/%postname%/ kasutajate mureks.

    kirjutas Aarne 31.03.2008 @ 23:03

  11. Haah, internet on ikka hĂ€mmastav asi, leidsin lĂ”puks ĂŒles, kust ma eelmine kord lahenduse sain :D
    ÜhesĂ”naga ma updatesin linnari blogi ja jĂ€lle lĂ€ks see charset tuksi. Kuna baasis on see vĂ€rk ju ikka parandamata.

    Uues wordpressis on vaja wp-includes/wp-db.php
    Rida 312 muuta: if ( defined(‘utf8’) )
    ja korras! :)

    kirjutas Allar 20.11.2008 @ 23:08

Kommenteeri postitust