Woopra plugin WordPress’ile

Aarne bloogKui sa kasutad Woopra't ja WordPress'i, siis ilmselt meeldib sulle ka uus WordPress'i plugin. Kui oled tõsine blogija, siis tahad, et su leht oleks standarditele vastava koodiga ja ilusasti valideeruv.

Kahjuks uus plugin genereerib sulle mittevalideeruva koodi. Õnneks ei ole parandamine keeruline.

  • Tõmba endale eelpool viidatud lehelt WordPress'i plugin
  • Paki failid lahti
  • Võta Notepadis või mõnes teises lemmikeditoris lahti fail woopra.php
  • Otsi üles rida 77
  • Otsi sellel real üles koht "...&size=..." ja asenda "...&size=..."
  • Otsi samal real üles koht "...&default=..." ja asenda "...&default=..."
  • Lõpptulemus peaks välja nägema umbes nii:
    Woopra plugin
  • Saada failid FTP abil .../wp-content/plugins/woopra/ kataloogi. Oluline on, et kataloogi nimi oleks just "woopra", muidu plugin ei tööta.
  • Aktiveeri plugin
  • Sisesta Settings / Woopra Settings alt oma Website ID ja pane paika muud seaded
  • Vaata Dashboard / Woopra Analytics alt üha suuremat rahulolevate külastajate tulva

Ongi kõik. Nüüd on Woopra plugin ilusti paigaldatud ja su blogi kood valideerub jälle. Õpetus kehtib nende puhul, kes kasutavad enda hostitud WordPress'i. Ja tegelikult ei saa ma aru sellest, kuidas need tegelased, kes töötavad välja laheda veebianalüütika programmi, ei suuda teha nii, et nende plugin töötaks ilma äkkimata ilusasti.

* * *

Kas "valideeruv" on üldse eestikeelne sõna? Minu võõrsõnastikus niisugust sõna pole. On väljend "valiidsus" mille vasteks annab 1999 aasta TEA Võõrsõnastik "valiidsus jur õigus- e seadusjõulisus; kehtivvus; psühh testi omadus täita oma otstarvet; testisobivus".

Sildid: #, #, #, #, #, #, #, #

Kommenteeri: