Uuele Firefoxile vana add-on

TöölaudIga kord, kui uus Firefoxi versioon välja tuleb tekkib paljudel ikaldus: lemmik add-on ei toeta veel uuemat versiooni. Mõnikord on asi tõsine ja add-on pole tõesti võimeline uue Firefoxi versiooniga koos töötama. Teine kord võib asi olla lihtsalt selles, et arendaja pole viitsinud üht väikest muudatust teha.

Teeme selle muudatuse siis ise ära!

Salvesta vajaliku add-on’i .xpi fail kõvakettale. Ehkki tema laiend on .xpi on tegu siiski tavalise .zip failiga. Paki allatõmmatud .xpi fail lahti.

Leia fail intall.rdf ja ava see näiteks Notepadis. Leia failis niisugune koht:

<em:targetApplication>
<Description>
<em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
<em:minVersion>1.0</em:minVersion>
<em:maxVersion>3.5.*</em:maxVersion>
</Description>
</em:targetApplication>

Muuda paksus kirjas oleval real versiooninumber enda Firefoxi versiooninumbri järgi sobivaks.

Paki failid kokku .zip failiks ja nimeta .zip ümber .xpi’ks.

Installi add-on Firefoxis valides "Fail" menüüst "Open File...".

Loomulikult on niisugune häkerdamine igaühe enda vastutusel. Minul on alati kõik add-on’id niimoodi tööle saadud ja probleeme pole esinenud.

Tagged with: , ,
2 comments on “Uuele Firefoxile vana add-on
  1. Kaspar says:

    krt, FF 4.0.1 saab pettusest aru ja ütleb, et fail on corrupt..
    RDF-i süntaks paistab ka muutunud olevat:

  2. Kaspar says:

    (sulg lahti)

    RDF:Description RDF:about=”rdf:#$ZUQlk2″
    em:id=”{ec8030f7-c20a-464f-9b0e-13a3a9e97384}”
    em:minVersion=”3.0″
    em:maxVersion=”4.0.*”
    /(sulg kinni)

Kommenteeri: